Macmillan Education

Support articles
The information you need at your fingertips

What are the system requirements for Macmillan Practice Online?

The system requirements for Macmillan Practice Online are as follows:

Safari 10.1
Mac 10.12 Safari 10.1
Mac 10.12 Chrome 64.0
Mac 10.11 Safari 9.1.3
Mac 10.11 Chrome 64
Windows 10 Chrome 64
Windows 10 Firefox 58
Windows 10 IE Edge 20
Windows 8.1 IE 11
Windows 7 Chrome 64
Windows 7 Firefox 58
Windows 7 IE 11
IOS Device Ipad (iOS 10)
IOS Device iPhone 6 (iOS 9)
Android Chrome (Android 6)
Android Chrome (Android 5.1)
Android Chrome (Android 7)

Did you find this article helpful?

YesNo